Commit 1c6cd9c0 authored by Tiago Peixoto's avatar Tiago Peixoto

Implement --with-python-module-path in configure.ac

This allows ones to specify exactly where the module will be installed.
parent 9a589107
......@@ -184,6 +184,17 @@ AC_PYTHON_DEVEL([== '${PYTHON_FULL_VERSION}'])
[CPPFLAGS="${CPPFLAGS} ${PYTHON_CPPFLAGS}"]
[LDFLAGS="${LDFLAGS} ${PYTHON_LDFLAGS}"]
# default directory for submodules
[MOD_DIR="${PYTHON_SITE_PKG}"]
AC_ARG_WITH([python-module-path], [AS_HELP_STRING([--python-module-path=DIR],
[directory where python module will be installed
[default=auto-detected] ])],
MOD_DIR=$withval)
echo "graph-tool will be installed at: ${MOD_DIR}"
[MOD_DIR="${MOD_DIR}/graph_tool"]
AC_SUBST(MOD_DIR)
echo "==========================="
echo "Using python version: ${PYTHON_FULL_VERSION}"
echo "==========================="
......@@ -356,10 +367,6 @@ AC_SUBST(CXXFLAGS)
-DHAVE_CONFIG_H"]
AC_SUBST(MOD_CPPFLAGS)
# default directory for submodules
[MOD_DIR="${pythondir}/graph_tool"]
AC_SUBST(MOD_DIR)
# default LIBADD flags for submodules
[MOD_LIBADD="${PYTHON_LDFLAGS} -l${BOOST_IOSTREAMS_LIB} -l${BOOST_PYTHON_LIB} \
-l${BOOST_REGEX_LIB} ${OPENMP_LDFLAGS} -lexpat"]
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment